Поиск по сайту

Обзор, настройка и тест MikroTik CAP ac

12.03.2018

Обзор, настройка и тест MikroTik CAP ac

Компания MikroTik представила новое поколение устройств на базе Qualcomm IPQ-4018 CPU 4x ARM 32bit Cortex A7

Линейка включает в себя следующие устройства: cAP ac, SXTsq 5 ac, DISC Lite5 ac, LDF 5 ac, hAP ac²

И Qualcomm IPQ-4019 - wAP 60G AP, wAP 60G AP

IPC4018 первая в отрасли полностью интегрированная система интеллектуальных шлюзов на плате (SoC), включающую следующее поколение Qualcomm® Internet Processor (IPQ), Qualcomm® VIVE ™ с Qualcomm® MU | EFX MU-MIMO, встроенный Gigabit Ethernet, Qualcomm® StreamBoost ™, с поддержкой двухканальной одновременной передачи (DBS) и транзитной передачи LTE.

Особенности продукта включают четыре ARM-ядра Cortex-A7 (638 МГц), DDR3L-1333 + DBDC 2-stream 802.11ac Wave 2 MU-MIMO Wi-Fi + 5-портовый коммутатор Gigabit Ethernet и два интерфейса xGMII. Для разгрузки основного CPU есть два отдельных сопроцессора для модулей Wi-Fi, аппаратное ускорение NAT, а также элементы ARM TrustZone: криптодвижок, безопасная загрузка ОС

IPQ-4018 объединяет две радиомодуля 2x2, обеспечивающие максимальную скорость PHY до 1,73 Гбит/с, четырехядерный процессор ARM и коммутатор Gigabit Ethernet в одном чипе. IPQ-4018 является первым в отрасли полностью интегрированным решением Wave 2 MU-MIMO Wi-Fi. Это недорогое и экономичное решение, которое позволяет производителям оригинального оборудования (OEM) использовать преимущества 11ac для основных сегментов. Кроме того, IPQ-4018 имеет гибкость при настройке своих радиоинтерфейсов для традиционной двухдиапазонной одновременной работы 2,4 ГГц и 5 ГГц или для двух диапазонов 5 ГГц

IPQ4018 спецификация чипсета

Wi-Fi Wi-Fi Standards 802.11ac Wave 2, 802.11n, 802.11p
Wi-Fi Spectral Bands 2.4 GHz, 5 GHz
Peak speed 1.733 Gbps
Channel Utilization 20/40/80 MHz, 5/10/20/40 MHz
MIMO Configuration 2x2 (2-stream)
Wi-Fi Features MU-MIMO, TxBF
RF Ethernet 5-port ethernet
USB USB Version USB 3.0, USB 2.0
CPU CPU Clock Speed 717MHz
CPU Cores Quad-core CPU, 4x ARM Cortex A7
DSP DSP Technology SIMD DSP
Process Process Technology 40 nm
Security Support Security Features Qualcomm® Trusted Execution Environment, Crypto Engine, Secure Boot
Wi-Fi Security WAPI, TKIP, AES-GCMP, AES-CCMP, WEP, WPA, WPS, WPA2, 802.11i security, PRNG
Memory

RAM

256 MB RAM

Memory Type

DDR3L
Interface

Supported Interfaces

USB 3.0, UART, USB 2.0, I²S, SPI, I²C, JTAG, Ethernet
Package

Package Type

QFN

Package Size

14 x 14 mm

Спецификации

И так рассмотрим, что же из этого огромного выбора оставила нам компания Mikrotik

Процессор - Architecture ARM 32bit CPU IPQ-4018 CPU core count 4 CPU подняли частоту до 716 MHz

Память - Size of RAM 128 MB Storage size 16 MB

Питание - максимальное энергопотребление 13W, единственный вариант питания устройства по PoE -802.3af/at PoE, out Passive PoE up to 57В, PoE in  теперь уже стандартный вольтаж 17-57В (вместо 18-30В)

Беспроводной интерфейс cAP ac - RBcAPGi-5acD2nD

cAP ac - RBcAPGi-5acD2nD

cAP ac - RBcAPGi-5acD2nD

cAP ac - RBcAPGi-5acD2nD

cAP ac - RBcAPGi-5acD2nD

В отличие от hAP ac² который распологает лишь двумя совмещенными антеннами (2.4/5G), у cAP ac - 4 антенны.

К большому сожалению на данный момент MU-MIMO, TxBF не реализовано на уровне драйвера.

Не смотря на то что на уровне драйверов реализованна полоса 160МГц выбрать ее программно не представляется возможным на данный момент

IPQ-4018 - 2.4 GHz number of chains 2, 802.11b/g/n, Antenna gain 2 dBi

IPQ-4018 - 5 GHz number of chains 2, 802.11a/n/ac, Antenna gain 2.5 dBi

Ethernet - 2x10/100/1000 Ethernet ports

Wireless specifications

2.4 GHz Transmit (dBm) Receive Sensitivity
1MBit/s26-100
11MBit/s26-94
6MBit/s26-96
54MBit/s23-78
MCS026-96
MCS722-73
5 GHz Transmit (dBm) Receive Sensitivity
6MBit/s26-96
54MBit/s21-80
MCS026-96
MCS720-75
MCS918-70

Внешний вид

Устройство имеет корпус из светло кремового матового пластика, имеющий круглую форму диаметром 13.6 сантиметров и высотой 3 сантиметра. Присутствуют отверстия для вентиляции на круглом штатном корпусе, а так же кнопка круглой формы по центру.

Присутствуют 7 индикаторов режимов работы точки доступа расположенные на верхней крышке. Два гигабитных разъема для подключения сетевого кабеля и две скрытые кнопкаи сброса/перезагрузки и выбора режимов находятся в нише на дне корпуса.

Плюсом является то, что устройство умеет получать питание только через сетевой кабель по технологии PoE (12 - 57 В, 13 W) на одном порту и при необходимости отдавать питание на втором порту.

Тест производительности LAN интерфейсов

Производитель заявляет следующие полученные им результаты тестирования производительности

устройство тестировалось на актуальной версии RouterOS RouterOS 6.42rc39 (Release candidate) firmware 6.42rc39, ввиду не корректной работы wifi на RouterOS 6.41.2 (Current) firmware 6.41.2

Ethernet test results

RBcAPGi-5acD2nD IPQ-4018 1G all port test
Mode Configuration 1518 byte 512 byte 64 byte
kpps Mbps kpps Mbps kpps Mbps
Bridgingnone (fast path)162.51973.4469.91924.71484.8760.2
Bridging25 bridge filter rules162.11968.5352.91445.5359.2183.9
Routingnone (fast path)162.51973.4469.91924.71488761.9
Routing25 simple queues162.51973.4469.91924.7506.3259.2
Routing25 ip filter rules162.21969.8240.8986.3242.9124.4

Проверим Bridging c помощью программного продукта IxChariot

Throughput

Group/ Pair Average (Mbps) Minimum (Mbps) Maximum (Mbps) Throughput 95% Confidence Interval Measured Time (secs) Relative Precision
All Pairs1 346,845176,991941,177
Pair 1718,313291,971941,1777,08655,6860,986
Pair 2635,845176,991701,75411,66155,6111,834
Totals:1 346,845176,991941,177

Transaction Rate

Group/ Pair Transaction Rate Average Transaction Rate Minimum Transaction Rate Maximum Transaction Rate 95% Confidence Interval Measured Time (secs) Relative Precision
All Pairs16,9272,21211,765
Pair 18,9793,65011,7650,08955,6860,986
Pair 27,9482,2128,7720,14655,6111,834
Totals:16,9272,21211,765

Response Time

Group/ Pair Response Time Average Response Time Minimum Response Time Maximum Response Time 95% Confidence Interval Measured Time (secs) Relative Precision
All Pairs0,1190,0850,452
Pair 10,1110,0850,2740,00155,6860,986
Pair 20,1260,1140,4520,00255,6111,834
Totals:0,1190,0850,452

Производительность с шифрованием мы проверим позднее и добавим результаты

IPsec test results

RBcAPGi-5acD2nD IPQ-4018 IPsec throughput
Mode Configuration 1400 byte 512 byte 64 byte
kpps Mbps kpps Mbps kpps Mbps
Single tunnelAES-128-CBC + SHA137.9424.559241.761.631.5
256 tunnelsAES-128-CBC + SHA136403.238.5157.739.820.4
256 tunnelsAES-128-CBC + SHA25636403.238.5157.739.820.4
256 tunnelsAES-256-CBC + SHA134.4385.337.9155.239.820.4
256 tunnelsAES-256-CBC + SHA25634.4385.337.9155.239.820.4

Беспроводной интерфейс WLAN сравним с Unifi AP-AC-PRO

Тестировать будем точку с одним клиентом на максимальную скорость в диапазоне 5G, к сожалению на данный момент мы не распологаем клиентскими устройствами с поддержкой MU-MIMO в большем количестве, тестировать скорость с устройства IPQ-4018 на IPQ-4018, и скорость передачи в дипазоне 2.4G, никакого практического интереса не представляет

Исходные данные:

  • устройство CAP ac тестировалось на актуальной версии RouterOS RouterOS 6.42rc39 (Release candidate) firmware 6.42rc39 (MU-MIMO, TxBF не реализовано на уровне драйвера)
  • устройство UniFi AP-AC-Pro тестировалось на актуальной версии Unifi контроллера 5.6.30 firmware 3.9.19.8123
  • клиентское устройство с Realtek RTL8822BE Wireless LAN 802.11ac PCI-E Network Adapter (802.11ac 2x2, Wave-2 compatible with MU-MIMO)

сэмулировали сценарий 8 потоков на загрузку, результат не особо отличается от такового с одним потоком, но можно сказать что каждый клиент получает 20-30мбит, с адекватной задержкой

Uplink 5G

Throughput


Group/ Pair Average (Mbps) Minimum (Mbps) Maximum (Mbps) Throughput 95% Confidence Interval Measured Time (secs) Relative Precision
cap ac 6.42.39 up 5g.tst283,734164,609343,3482,581140,9770,910
unifi ac pro uplink 5g.tst358,545283,688386,4731,117111,5620,312




Transaction Rate


Group/ Pair Transaction Rate Average Transaction Rate Minimum Transaction Rate Maximum Transaction Rate 95% Confidence Interval Measured Time (secs) Relative Precision
cap ac 6.42.39 up 5g.tst3,5472,0584,2920,032140,9770,910
unifi ac pro uplink 5g.tst4,4823,5464,8310,014111,5620,312




RSSI


Group/ Pair RSSI E1 Average RSSI E1 Minimum RSSI E1 Maximum RSSI E2 Average RSSI E2 Minimum RSSI E2 Maximum Number Unique AP
cap ac 6.42.39 up 5g.tst-50-50-50n/an/an/a1
unifi ac pro uplink 5g.tst-50-50-50n/an/an/a1




Response Time


Group/ Pair Response Time Average Response Time Minimum Response Time Maximum Response Time 95% Confidence Interval Measured Time (secs) Relative Precision
cap ac 6.42.39 up 5g.tst0,2820,2330,4860,003140,9770,910
unifi ac pro uplink 5g.tst0,2230,2070,2820,001111,5620,312




Downlink 5G

Throughput


Group/ Pair Average (Mbps) Minimum (Mbps) Maximum (Mbps) Throughput 95% Confidence Interval Measured Time (secs) Relative Precision
cap ac 6.42.39 down 5g.tst223,696165,631256,4101,374178,8140,614
unifi ac pro down 5g.tst276,556194,175327,8691,855144,6360,671




Transaction Rate


Group/ Pair Transaction Rate Average Transaction Rate Minimum Transaction Rate Maximum Transaction Rate 95% Confidence Interval Measured Time (secs) Relative Precision
cap ac 6.42.39 down 5g.tst2,7962,0703,2050,017178,8140,614
unifi ac pro down 5g.tst3,4572,4274,0980,023144,6360,671




Response Time


Group/ Pair Response Time Average Response Time Minimum Response Time Maximum Response Time 95% Confidence Interval Measured Time (secs) Relative Precision
Pair 1cap ac 6.42.39 down 5g.tst0,3580,3120,4830,002178,8140,614
Pair 1unifi ac pro down 5g.tst0,2890,2440,4120,002144,6360,671


 

Возможные скорости передачи данных при максимальной модуляции для устройств актуального стандарта 802.11ac Wave 2, учитываем что многие устройства поддерживают модуляцию 1024-QAM при 80 MHz, что выше спецификации 802.11 ac

Пространственных
потоков
20 MHz
256-QAM
(1 ch)
40 MHz
256-QAM
5/6
(2 ch)
80 MHz
256-QAM
(4 ch)
80 MHz
1024-QAM
(4 ch)
160 MHz
256-QAM
(8 ch)
160 MHz
1024-QAM
(8 ch)
1  200433.35418671084
2  400866.710841733.32166
3 28960013001625  
4  8001733.321663466.74334
8 69316003466.743346933.38668

866.6Mbps-80MHz/2S/SGI - максимум что доступно в текущий момент на устройствах Mikrotik CAP ac и WAP ac,

Воспроизведение видео с DLNA сервера

Важная и актуальная тема на текущий момент в домашних сетях которую нельзя не отметить это просмотр 4K видео c DLNA сервера через беспроводные сети.

Есть несколько моментов и ограничений с которыми придется столкнуться при его реализации:

- на RouterOS 6.41.2 (Current) firmware 6.41.2 стабильной работы не наблюдается

- на RouterOS 6.42rc37-39 (Release candidate) firmware 6.42rc37-39 все исправлено, рекомендуем к установке до начала эксплуатации CAP ac:

*) bridge - added host aging timer for crs3xx and Atheros hw-bridges;
*) bridge - fixed bridge port interface parameter under "/interface bridge host print detail";
*) bridge - fixed false MAC address learning on hAP ac2 and cAP ac devices;

*) wireless - fixed RTS/CTS option for the ARM based wireless devices;
*) wireless - improved compatibility with specific wireless AC standard clients;
*) wireless - improved packet processing on ARM platform devices;

- требования к количеству ошибок и полосе пропускания приведены ниже в таблице

- h264 h 265 кодек который может генерировать реальную полосу порядка 150 Мбит (120GB UHD Blu-ray)

- большинство топовых моделей 4K плееров и 4K UHD телевизор имеют LAN порт 10/100 Мбит/c

- wifi модули 4K UHD телевизоров напротив имеют 80 MHz 256-QAM (4 ch) - 866.6Mbps-80MHz/2S/SGI этого больше чем предостаточно

Требования к пропускной способности видео и скорости передачи данных

Video type Description Rate Packet error rate Jitter Delay
Uncompressed720p (RGB) 1280x720 pixels; 24 bits/pixel, 60 frame/sec1.3 Gbps1085msec5msec
1080i (RGB) 1920x1080/2 pixels; 24 bits/pixel, 60 frame/sec1.5 Gbps1085 msec5 msec
1080p (YCrCb) 1920x720 pixels; 24 bits/pixel, 60 frame/sec1.5 Gbps1085 msec5 msec
1080p (RGB) 1920x720 pixels; 24 bits/pixel, 60 frame/sec3.0 Gbps1085 msec5 msec
Lightly compressedMotion JPEG2000150 Mbps10710 msec10 msec
H.26470 – 200 Mbps107
108
20 msec20 msec
CompressedBlu-ray™50 Mbps10720 msec20 msec
HD MPEG220 Mbps3x10720 msec20 msec

Качество воспроизведения 4K видео с DLNA сервера проверяли на встроенном в TV плеере

проигрывались Batman v Superman: Dawn of Justice 126GB UHD HDR BD полоса в среднем 156 Мбит и Mad Max: Fury Road BD UHD HDR 86GB

Нарекания по визуальным артефактам при воспроизведении и задержкам звукового ряда отсутствует, аналогично ситуация выглядит на эталонной на данный момент точке доступа UniFi AP-AC-Pro.

Настройка

Роутер

Точка доступа WiFi

/interface bridge
add fast-forward=no name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn channel-width=20/40mhz-XX \
disabled=no distance=indoors frequency=auto mode=ap-bridge \
ssid="unisi.ru" wireless-protocol=802.11 wps-mode=disabled
wireless-protocol=802.11 wps-mode=disabled
set [ find default-name=wlan2 ] band=5ghz-n/ac channel-width=20/40/80mhz-XXXX \
disabled=no distance=indoors frequency=auto hide-ssid=yes mode=ap-bridge \
ssid="unisi.ru" wireless-protocol=802.11 wps-mode=disabled
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=\
dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=\
123
/interface bridge port
add bridge=bridge1 interface=all
/interface wireless access-list
add authentication=no forwarding=no interface=wlan2 signal-range=-120..-70
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=bridge1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/system clock
set time-zone-name=Europe/Moscow
/system leds settings
set all-leds-off=after-1h
/system routerboard settings
set silent-boot=no

CAp

Настройки точки доступа - CAP

/system-reset no-defaults=yes

# полностью стираем конфигурацию роутера включая конфигурацию по умолчанию

CAPsMAN v2 unisi.ru

/system identity set name=AP

# задаем название точки

CAPsMAN v2 unisi.ru

/interface bridge add fast-forward=no name=bridge1
/interface bridge port add bridge=bridge1 interface=all

# учитывая изменения настроек bridge в RouterOS v6.40rc36-rc40 and v6.41rc1+ hardware offloading (hw-offload) добавим все доступные интерфейсы, protocol-mode автоматически будет rstp

protocol-mode (none | rstp | stp | mstp; Default: rstp) Select Spanning tree protocol (STP) or Rapid spanning tree protocol (RSTP) to ensure a loop-free topology for any bridged LAN. RSTP provides for faster spanning tree convergence after a topology change. Select MSTP to ensure loop-free topology across multiple VLANs.

CAPsMAN v2 unisi.ru

/interface wireless cap set enabled=yes interfaces=wlan1,wlan2 discovery-interface=bridge1

# вариант когда точка и контроллер — это разные устройства CAP ≠ CAPsMAN

/ip dhcp-client add interface=bridge1 use-peer-dns=yes add-default-route=yes disabled=no

# добавим dhcp-client на bridge он получит IP address, так как все удобства управления через VPN по MAC-адресу через winbox не доступны

CAPsMAN v2 unisi.ru

/ip service
set api disabled=yes
set api-ssl disabled=yes
set ftp disabled=yes
set telnet disabled=yes
set ssh disabled=yes
set www disabled=yes
set www-ssl disabled=yes

# отключим все не нужные сервисы кроме winbox, ssh - в последней версии RouterOS отсутствует

CAPsMAN v2 unisi.ru

/system package disable hotspot
/system package disable ipv6
/system package disable mpls
/system package disable ppp
/system package disable routing
/system package disable security

# отключим все не нужные пакеты в RouterOS после первой перезагрузки они будут помечены серым

Конфигурация CAPsMAN с сертификатами

CAP

#Зададим в конфигурации CAP запрос сертификата:

CAPsMAN v2 unisi.ru

/interface wireless cap set certificate=request

CAP будет подключаться к CAPsMAN и запрашивать сертификат. CAP получит форму CA-Certificate CAPsMAN, а другой сертификат будет создан для использования в CAP.

На устройстве CAP в меню CAP установлен требуемый сертификат:

 /interface wireless cap> /interface wireless cap print
enabled: yes
interfaces: wlan1,wlan2
certificate: request
lock-to-caps-man: no
discovery-interfaces: bridge1
caps-man-addresses:
caps-man-names:
caps-man-certificate-common-names:
bridge: none
static-virtual: no
requested-certificate: CAP-D46237916C00

Если вы хотите заблокировать CAP для определенного CAPsMAN и убедитесь, что он не будет подключаться к другим CAPsMANs, вы должны установить опцию Lock To CAPsMAN на yes. Кроме того, вы можете указать CAPsMAN для блокировки, установив общие имена сертификатов CAPsMAN на устройстве CAP:

CAPsMAN v2 unisi.ru

/interface wireless cap
set lock-to-caps-man=yes
set caps-man-certificate-common-names=CAPsMAN-D46237916C00


Возврат к списку